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Real-time control of PA systems ‒ Made in Germany 

DXO Control is an intelligent and powerful software for remote controlling of the digital PA controllers    
DXO-26PRO and DXO-48PRO MK1/MK2 as well as the PRIME system amplifier by PSSO.  
 
The control software enables a quick and effective programming of presets for your speakers systems. All 
adjustments can be made like via the menu of the individual units, however, the presentation is much more 
clearly arranged. 
 
Users have full control over the built-in DSP modules of the units and can load, edit and save all functions on 
the computer or transfer them into the internal memory of the controllers or the amplifier respectively. For this 
functionality, the units are connected via a wired Ethernet connection to the same network as the control 
computer, which can be connected either wired or through WiFi. Local connectivity of the DXO PA controllers 
to the control computer from a front-panel USB connector is also possible in order to download initial settings 
or as a fallback in case of network failure. 
 
The software runs on Windows 10 as well as on Mac OS X 11 and better. The operation is basically the 
same for all platforms; where differences exist they will be noted. 
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1 Installation  
 

1.1 PC and Mac 

To install the control software, start the installation 
program and follow the on-screen instructions. For 
Windows- and Mac-based computers, the software 
consists of two modules: the device manager that 
connects all units to the computer and the configuration 
window for adjusting the parameters. For iPad, both 
functions are integrated in a single window. In the 
following sections we will discuss DXO Control for 
Windows. However, Mac OS X will offer the same 
functionality. Individual options or their translations can 
change with software updates. 

 

 
 
 
 
 
 
 
 

 
Fig. 1  DXO Control on the MacBook 
 
Figure 1 shows DXO Control on the MacBook. To 

enable the software to connect to any of your devices, 
you must either disable your internet firewall or include 
the application in the list of programs that are allowed 
access through the firewall. Switch on your device and 
launch DXO Control. The device manger will show the 
devices found on the network together with their 
mac address and IP address, similar to figure 3. The ‘>’ 

icon at the right side for launching the configuration 
window may be either > or >. When >, the unit is online 
and can be activated by clicking the > icon.  

 

1.2 iPad and iPhone 

 
 
 
 
 
 
 
 
 
 
Fig. 2  DXO Control on the iPad 

 
The app DXO-Control for iPad is available as a free 

download on the App Store. In addition, a version with 
limited functionality is available for iPhone. 
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2 Device manager 

 

 
 
Fig. 3  The device manager 
 
The main purpose of the device manager is to select a 
particular unit for manipulation and/or to group several 
units in a group. Use File > Exit to exit the program. 
The available Tools commands are shown in figure 4.  
 

Note: You can modify the unit name in the 

configuration. 
 

 
 
 
 
Fig. 4  The “Tools“ menu 
 

2.1 Tools > Set Software Password  

It is possible to set up a password to access the 
graphical DSP software main screen. This will be 
discussed in more detail later in section 3.2.6. 
 

2.2 Tools > New Group  

This command allows you to combine several online 
units into a named group. The group will be added to 
the list (row Group: 8) in the device manager (�fig. 
5). 

 

 

Fig. 5  Showing a group in the device manager 
 
Clicking the cross icon x on the right deletes the group; 

clicking the blue tool icon opens a screen where you 
can select the members of the group; you will be able to 
select any unit which is online to become a member of 
the group. A further selection from this screen opens a 
dialog where you can specify which parameter, for 
which setting and for which channel you wish to link 
within the group. For instance, you can link only gain, or 
gain and limiter settings for only output channels. An 
example setting screen is shown in figure 6. 

 

 

 
Fig. 6  Sample dialog box showing linked items for a 
   group  

     

2.3 Tools > Enter Demo Mode  

Allows you to exercise the functionality of a DXO/ 
PRIME unit without hardware present for training and 
familiarization purposes. Various virtual units with the 
additional designation “DEMO8“ will be added to the 

list. 
 

2.4 Tools > Disable/Enable Updates 

When set to Enable Updates, there will be an indication 
when firmware updates for the unit will be available. 
This is shown on the right edge of the unit identification 
in the control program with a ‘rotary’ icon, see figure 7. 

The icon turns orange when updates are available. 
Clicking the icon will initiate the download and 
installation of the update.  
 

 
 
Fig. 7  The ”rotary” icon at right indicates firmware  
  update for this unit is available   
 

Notes: The control program and the unit must be 

equipped with matching firmware versions 
to ensure smooth communication. If the 
version of DXO Control is newer, the 

firmware of the units may be updated via 
the control program. With this update, all 
settings saved on the units will be lost. To 
keep the settings, save them on the 
computer (�section 3.1.1). 

 Units connected via the USB interface 
cannot be updated. To update these units, 
connect them via the Ethernet interface. 
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2.5 Launching the configuration 
window 

Clicking the green > icon at the right of the connected 

unit info line in the device manager will load the 
configuration window for the unit. At this point, the 
software will go through a synchronization cycle and, if 
a PIN was defined before, will ask for the PIN (�section 
3.2.6.). 
 
The configuration interface screen will come up similar 
to figure 8; this is the opening screen of the actual 

application controlling the settings of the unit. Any 
settings changed will be instantly transferred to the 
units. 
 

Note: The iPad app does show a screen similar to 

figure 8; as mentioned, there is no separate 
device manager but the connectivity and 
address data is shown at the bottom of the 
graphical screen. 
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3 Configuration window: 

menu bar 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
Fig. 8  Configuration window   
 
Figure 8 shows the main screen from which all setup 
screens and options can be reached. 
 

3.1 File commands 

3.1.1 File > Open and File > Save  

Presets are the collections of all settings for a particular 
configuration. They can be saved on the computer or in 
the actual unit. With these commands you can save a 
complete setting and reload it at a later time.  
 

3.1.2 File > Backup presets and File > Restore 
presets  

These commands operate similarly to Save and Open, 
but in addition offer the choice to use the .preset file 
format or the .txt format. Text files are a way to archive 
a particular set of settings for documentation purposes.  
 
 

Note:  The same functionality is available directly 

on the center column under Presets Local 
using the buttons Store and Load. 
Saving/loading presets in .txt format is 
inhibited when the unit is locked (�section 
3.2.4). 

 

3.1.3 File > Create Flash Image  

For data backup or data transfer to a different unit, the 
entire settings and presets as well as the firmware of a 
unit can be saved in a flash image file: Call up the menu 
item File > Create Flash Image and select a file name 

and a storage location.The file can then be loaded via 

the menu item File > Load Factory File. A flash image 

first triggers a firmware update and before the factory 
file is being loaded. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.1.4 File > Quit  

Call up this menu item to exit the program or close the 
window. 
 

3.2 Hardware commands 

The hardware menu offers several functions as shown 
in figure 9. 

 

 
 
Fig. 9  Hardware commands 
 

3.2.1 Hardware > Enter password  

To be discussed in section 3.4. 
 

3.2.2 Hardware > Configure  

The Configure menu item opens an additional screen 

where several options are presented. However, the 
options shown will depend on the access level currently 
in force. 
 

3.2.3 Hardware > Configure > Power On Preset 
This menu allows you to select a preset that will be 
automatically loaded at power-on; however any 
changes to this preset will not be saved to the next 
power-on cycle unless you explicitly do so. If you select 
the option Last Setting, the unit starts with the settings 

most recently made before it was switched off. 
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3.2.4 Hardware > Lock Unit  

Clicking this menu item will lock/unlock the unit to block 
unwanted changes. The Locked State is the lowest 
access level. When locked, the display only shows 
output levels but no controls or other settings, and 
nothing can be changed, as shown in figure 10. The 
actual operation of this function depends on the access 
level in force as described in section 3.3.3). 
 
An attempt to lock the unit will generate a warning that 
unlocking will only be possible with a valid password or 
a password of a higher level. The factory-set password 
is: Password. Users can change this password for 

each unit individually. 
 

 
 
Fig. 10  ”Locked State“   

 

3.2.5 Hardware > Go to Standby/Exit Standby  

Go to Standby will place the unit in standby. In this 

state, outputs are disabled but all settings can still be 
manipulated. 
 
To return to the normal mode, call up menu item Exit 
Standby. 

 

3.2.6 Hardware > Set PIN  

Clicking this option allows you to enter a 4-digit PIN 
number. When this is set, you will need to enter the PIN 
number at any time you attempt to access the software 
or when the software needs an input. This is a separate 
function to the access level control. The PIN control can 
be switched off by entering a PIN of 0000.  

 

3.3 Access levels and locking 

There are up to four access levels with different rights 
available. The setting options available for users 
depend on the access rights of the current access level. 
The levels are accessed by different passwords. These 
features are in addition to a software password 
described in section 3.2.6.  
  

3.3.1 Entering passwords 

The passwords are entered via menu item Hardware > 
Enter Password. The following table shows the access 

levels in descending order and the corresponding 
passwords. 
 

Access level Password 

Development* develop 

Administrator admin 

User user 

Locked State - 

*not DXO-48 PRO MK2 
 
Note: These passwords are factory-set. We 

suggest changing the passwords after the 
purchase. Changes can be made in the 
respective access level or in a higher 
access level. Store your passwords in a 
safe place! 

 

At start-up the respective unit will usually be in the 
access level User. There is no specific indication that 

you are in user mode. However, administrator and 
developer mode will be indicated at the top of the 
window. To go to a higher access level, enter the 
corresponding password. 
 

3.3.2 Changing passwords 

To change the passwords, call up menu item Hardware 
Hardware > Configure > Change Password. To 

change the password of the current level, first enter the 
current password, then enter the new password, and 
finally reenter the new password to confirm it. 
Passwords for lower access levels can be directly 
entered and will also be displayed. 
In the Development level, individual presets can be 

saved with separate passwords. Prior to saving a 
password, make the desired settings via the menu 
Preset > Passwords > Admin Password/Developer 
Password.  
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3.3.3 Changing access rights 

Via the menu branch Hardware > Configure > Access 
Rights, the access rights for lower access levels can be 
defined. Figure 12 shows the options and factory-set 
values for the Administrator level. 

 

 
 
Fig. 12  Access rights for the Administrator level 
 

Particular rules apply concerning the access to the 
settings of the input parameters and output parameters. 
The access rights for these settings (Access Input/ 
Output Channel) are exclusively saved on the level 
Development together with the corresponding preset. 

Prior to saving a preset, make the settings desired via 
the corresponding menu Preset > Access Rights > 
Locked/User/Admin Access Rights. 

 

3.3.4 Locking 

Call up the menu item Hardware > Lock to go to the 
lowest access level Locked State. 

 

3.3.5 Configuration suggestions 

Go to the menu item Hardware > Configure to call up 

specific configuration suggestions.This will preset 
specific channel linkages and signal assignments by 
means of the controls MIXER (�chapter 9) that can be 
used as the basis for further settings. 
 

3.4.6 Configuration of digital inputs 

When the signal of the digital input AES / EBU is used 
for the inputs IN 3 and IN 4 with the DXO-48 PRO MK2, 
it will be possible to automatically switch to the analog 
inputs if the digital signal is not available. 
 
Call up the menu item Hardware > Configure > AES -
> Analog Failover to enable (on) or disable (off) 

automatic switching to the analog inputs.  
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4 The configuration 

window: control elements 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
Fig. 13  Main setup screen   
 
The buttons on the left side bar of the main screen can 
be used to go to the other views, i.e. the crossover 
settings, the input settings and the output settings 
(�Fig. 13). 

 

4.1 Local presets  

These commands allow you to save and re-load 
configurations as .preset files on the local computer.  
 

4.2 Unit presets  

These commands are similar as the other Save and 
Load commands but with the distinction that presets 
can be saved to and reloaded from the unit‘s internal 
memory. Select the storage location from the list field 
and enter a name in the upper field. 
 

4.3 Link  

Under Link there are several status related indications. 
The indicator lamp at the right will be green for an 
active link or red when the unit is offline. The name and 
MAC address of the connected unit is also shown.  
 

4.4 Unit name 

Shows the unit name of the connected unit, which can 
be edited by typing in a new name. The new name will 
be reflected in the Link slot as well as in the device 
manager (�Fig. 3). 

 

4.5 Channel settings 
On the right side are the channel settings. This area is 
divided into several subsections: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.5.1 Gain controls for the input channels 

These sliders control the level from each of the physical 
input connectors as send to the input processing 
channels. Channel numbers are shown at the bottom 
line. Level settings are also shown numerically below 
the sliders, and can also be set by entering a specific 
value in a field. 
 

4.5.2 Gain controls for the output channels 

These sliders control the levels for the physical Output 
channels at the rear-panel output connectors. Level 
settings are also shown numerically below the sliders, 
and can also be set by entering a specific value in a 
field.  
 
Sliders auto-zero: Whenever you double-click on a 

slider, that slider moves to the 0 dB position. This 
operates on all views and screens. When two channels 
are linked, the odd-numbered channel can be used to 
manipulate the two linked channels. The even-
numbered channel of a linked pair will be unresponsive 
but follow the odd-numbered channel settings. To reset 
a paired level to 0 dB you must therefore double-click 
the odd-numbered slider.  
 

4.5.3 Link switch 

When activated, level settings for the related pair of 
channels pairs are linked together and can only be 
changed with the left-hand, even-numbered slider of the 
pair. The right-hand slider will follow. Similarly, entering 
numeric values in the level fields will only be accepted 
for the left channel of a pair, with the right-channel 
numeric value following.  
 

4.5.4 Mute switch 

Allows muting of an input or output channel on a per-
channel basis, independent of any linking in effect. 
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5 X-over view 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
Fig. 14  X-over view 
   
When you click X-over in the left main screen function 
list, most of the screen is dedicated to the controls and 
indicators for setting up the crossover filters as shown 
in figure 14.  

 
The graphical screen shows the crossover settings for 
each of the output channels in dedicated colors. The 
cut-off frequencies are represented by triangular 
marking above the curve. To change the frequency, 
move the corresponding marking with the mouse (as an 
alternative to the numeric input). The available range is 
from 20 Hz to 20 kHz. 
 

5.1 Filter type 

The filter type and slope for each output channel and at 
each end of the band can be set by selecting the 
desired type from the drop-down menu below the 
graphical area, for that channel. Separate filter types 
are available for the HP and the LP setting.  
 

5.2 Gain 

The output channel gain, in dB, can be set by entering a 
numerical value in the field indicated by ‘G’. The gain 
value entered here will have the same effect as in the 
main view. 
 

5.3 Delay 

For each channel a delay can be introduced in the 
numeric field indicated by ‘D’, in milliseconds. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5.4 Link 

When two channels are linked by activating the related 
link button in the top right-hand side of the screen, the 
settings for that pair are combined and only a single 
color and number icon for the pair is shown in the 
graphical screen (only the odd number of the pair is 
shown). Also in this case, all numerical values and filter 
types for the two channels are linked and can only be 
changed in the left hand side (odd numbered) channel 
of the linked pair. 
 

5.5 Mute and phase invert 

Changes to the mute status of a channel or channel 
pair will also reflect in the main screen and vice versa. 
Mute status of an individual channel can be changed 
independent of whether a channel is linked to another 
channel. However, the phase invert status will be linked 
for two channels if the channels are linked. 
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6 Input channel view  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Fig. 15  Input channel view 
   

Clicking on an input channel number in the main screen 
will bring up the input channel screen (�Fig. 15). In this 

screen, individual input channels can be equalized 
and/or filtered.  

 

6.1 Filtering and EQ 

All input channels can have filtering and equalization 
applied individually, or as linked pairs. Input channels 
can be linked in the min screen, and in that case, all EQ 
and filter settings for the pair will be linked. EQ can be 
set either in the graphical screen by cursor dragging, or 
in the numerical fields and drop-down lists below the 
graphical screen. Type, Frequency, Q/BW and Gain 
can be set for each input or pair of linked inputs. All 
settings are reflected real-time in the graphical screen. 
The Q/BW column toggles from indicating filter Q or 
filter bandwidth (BW) every time the column label is 
clicked.  
 

6.2 Curve diagram 

On the graphical screen, a white curve represents the 
compound transfer curve for that input channel. Each 
filter has a point of reference (small square with filter 
number) and a frequency curve in a specific color. The 
frequency response resulting from all active filters is 
represented by a white curve. Some of the filters can be 
set graphically via the mouse: 

– move horizontally to change the frequency 

– move vertically to change the gain 

– move horizontally with the right mouse button to 
change the quality factor/bandwidth 

– double-click a point of reference to switch the 
corresponding filter on or off 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Alternatively, you can either click the black/blue button 
next to each EQ or the HPF or LPF filter at the bottom 
of the screen, or you can double-click on the numbered 
square of the elements in the graphical screen. Even if 
the effect of the element on the compound curve is 
removed, the colored contributing curve of the element 
remains visible. This is a useful functionality to review 
the contribution of several interacting filter and EQ 
settings on a channel.                                      
 
The actual contribution of an element is always 
reflected in the blue on/off button next to each element. 
 

Note: The white compound transfer curve also 

reflects any crossover settings made in the 
X-over screen, when activated at the HPF 
and LPF buttons at the bottom of the 
screen. 

 

6.3 Tools 

On the left-hand side of the graphical screen are four 
icons to help precise settings. The top Arrow icon 

expands the graphical screen to the size of the window. 
Clicking this icon again from the expanded screen 
expands it to the full display size. In either of the 
expanded settings, clicking the X-icon at the top left will 

collapse the graphical area to the default setting. 
 

The camera icon will generate a .png picture 

file similar to a screen shot which you can 
save for documentation or instruction 
purposes. 
 

The T(ext) icon will show/hide the values of all 

active filters in the graphical screen. These 
settings will anyway be visible when changes 
are being made, but with the T icon activated, 
they will be visible continuously. This 
duplicates the numerical indications in the 
lower part of the screen but it will be useful 
with the expanded screens mentioned before. 
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For very accurate settings of EQ or filtering you can 
click the looking glass icon. All movements of the 

cursor now have a much smaller effect and you can 
drag curves with much greater precision. Clicking the 
looking glass again reverts to normal operation. 
 

The bottom symbol opens the RTA function (�chapter 

7). 

 

6.4 Input gain and mute  

The right hand side of the screen shows the slider to set 
input channel gain and, next to it the level indicator. The 
field for numerical input of the gain value is below the 
control. The mute button mutes the corresponding 
input. Settings in this view have the same effect as in 
the main view. 

 

6.5 Delay, limiter and compressor 

In the bottom right of 
the input screen there 
are settings for 
channel delay, limiter 
(-46 to +24 dBu) and 
compressor release 
rate (13 to 99 dB/s) 
settings. Channel 
delay can be set in a 

variety of distance or time units from the drop-down list. 
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7 Using the RTA function  
The RTA enables you to visualize the spectrum of the audio signal. By using this to measure the output of the 
loudspeaker producing white noise, you can find the transfer curve of the loudspeaker. Although other applications exist, 
we will focus on this application. To measure a transfer curve, connect a signal generator playing white noise, or select 
“White Noise” from the input selection drop-down in the DXO Control software. Adjust the volume to a reasonable level; 
there is no need for high SPL measurements unless you want to test power compression. Now go into the channel you 
want to adjust. For a 2-way system this may be the HF or LF channel, or it may be the input channel to adjust the overall 
transfer function. If you plan to use the RTA measurement to control a FIR filter, choose a channel that supports FIR.  

 

7.1 RTA measurement 

First you need to enable the RTA function. To do so, click the RTA icon in the graphical window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

Fig. 16  RTA symbol 
 

Note: DXO Control provides FIR calculation functions for hardware that supports FIR filters, and an RTA (Real 

Time Analyzer) option that can be used in combination with the FIR filter, but is independent from the 
hardware. This document describes the use of both options. It is assumed that you know what a FIR filter is, 
what the difference between IIR and FIR filters is and that you understand the concepts of truncating, 
convolution, group delay and related topics, as well as transfer function, power compression, directivity etc.  

 
The RTA function will be enabled. To start the measurement, click Play.  

 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
Fig. 17  Play 
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This will start the RTA with the default settings. A measured response will be shown:  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 18  Measured response 

 
Click Pause to stop measuring. 
 

 
 
 
 
 
 
 

Fig. 19  Stop measurement 
 

7.2 Measurement options 

Now that you have made a first measurement, let’s have a look at the measurement options. Click the Settings button. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
 
 

 
Fig. 20 Options 
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A window will open with the measurement options:  

 

 
 
 
 
 
 
 
 
 

 
Fig. 21  Options dialog 
 

Option Function 

Smoothing Choose the frequency smoothing. For manual measurements and settings, 1/6th 
or 1/3 Octave is recommended. For automatic FIR adjustment, this may lead to 
unexpected results due to room interference; in this case, a setting of 1/2 to 1 Oct 
is recommended.  

Avg Choose the number of measurements that are averaged. The averaging function is 
a moving average over Avg samples. For fast indications, 1 to 5 is OK; for 
accurate measurements, you may want to increase this value to 10 or more.  

FFT size The size (length) of the sampled data. With a size of 4k, lower frequencies are not 
accurately measured, but the measurement is fast. Larger size leads to more 
accuracy in the low region, but longer measurement times. To see the accuracy, 
try setting the smoothing to “Off”; then you will see the actual data points.  

One Shot When selected, one reading consisting of “Avg” measurements will be taken. 
When deselected, the measurement is continuous.  

Auto Mute / Unmute When selected, the software will automatically mute the hardware at the end of 
each measurement, and unmute it before the next measurement. Use this in 
combination with the One Shot setting to go easy on your neighbors.  

Input Select the source of the measurement. A proper measurement microphone is 
recommended; the measurement is only as good as the microphone.  

Auto Scale Manual scale is not supported yet. Please leave this check box selected.  

Show Filters Wenn diese Option abgewählt ist, werden die Frequenzgangkurven der Filter 
(PEQ, HPF, LPF, FIR) nicht angezeigt. Unterhalb der Optionen wird eine Liste der 
gespeicherten Messungen angezeigt. Wenn noch keine Messungen gespeichert 
wurden, werden nur die Standardkurven angezeigt:  

Last Measurement 

This is the as-yet-not-saved measurement. Select if it is visible or not by clicking 
“Visible”; select the color by clicking “Colour”.  

Weighted Result 

When saving multiple measurements, these can be combined into one. 

Select visibility and color here. Feel free to play around; it will not explode 

 

7.3 Saving and combining multiple measurements  

After making a measurement, look at the curve and see if it is plausible. Measurements can be distorted by nearby 
objects (walls, floor, people, bookshelves). Try measurements in different places to see what happens. When you are 
satisfied with a measurement, click the Save button.  
 
 
 
 
 
 

 

 

Fig. 22  Storing measurements 
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One more line is added to the measurements. You can set some options:  
 

Option Function 

Enabled  When deselected, this measurement will not be visible and will not be taken into 
account for the weighted result.  

Name You can set the name for each measurement.  

Weight The weight of each measurement determines the relative importance of each 
measurement when calculating the weighted result. For instance: When you have 
one measurement with weight 2 and another with weight 1, the first measurement 
will be twice as influential in the result. Choose any number other than zero.  

From The bottom end of the frequency range where this measurement is used. More on 
this on the next page.  

To The top end of the frequency range where this measurement is used. More on this 
on the next page.  

Visible When deselected, the measurement will not be visible, but will still be taken into 
account for the weighted result.  

Colour Select the colour of the displayed curve plot.  

 
Normally, one would make several measurements, e.g. for different listening positions to take the room into account, or 
from different angles w.r.t. the loudspeaker to take the directivity of the loudspeaker into account. We will not go into the 
details of why and how to measure for optimal results; that is not the scope of this document, and there is plenty of 
information on that in the Internet. 
 
After saving several measurements, the Settings window looks like this.  

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Fig. 23  Storing several measurements 

 
And the graphical window will look like this:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 24  Displaying several measurements 
 
Now you can combine these measurements into one averaged result. In the image above, measurements 2 and 4 have 
a greater weight than the other two; these would be e.g. on-axis results, or my favorite listening position. Now let’s 
assume that measurement 4 (the blue one, also the last one, so shown light grey here) was done close to the woofer, 
and I think this data is very useful for the low end up to 300Hz, but irrelevant for the rest of the frequency spectrum; and 
the other measurements are relevant for 300Hz and higher. 
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“From” and “To” fields are displayed as follows: 
 
 
 
 
 
 
 
 
 
 
Fig. 25  Editing 

 
The Last Measurement is set to invisible so as not to be in the way, since measuring is done for now. 
 
The graphical window will look like this:  
 
  
 
 
 
 
 
 
 
 
 
The Last Measurement is set to invisible so as not to be in the way, since measuring is done for now. 
 
Das grafische Fenster sieht dann wie folgt aus:  

 
 

Fig. 26  Invisible measurement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For more detail,click the Full Screen button. 
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Fig. 27  Full-screen mode 



 
 

 
 

You can play around with different frequency and weight settings to reach the desired weighted result. One more 
example: Settings. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 28  Settings dialog 
 
And the result: 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 29  Results 
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8 Using FIR filters 
There are 3 ways to define a FIR filter in DXO Control: Load from a file, create by using PEQs and crossovers to draw a 
target response, and by inverting the RTA measurement.  
 
When a unit is connected, the filter that is loaded will be shown on the display as a white line. In this example, no FIR 
filter has been loaded yet. Let’s change that, shall we?  

 

8.1 Creating a filter from parametric equalizers  
First, set some PEQs to create a target response, then click CALC in the FIR corner:  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 30  Open CALC dialog  

 
A pop-up window will appear with some options:  

 

Option Function 

Number of taps You can select how many taps of the FIR 
filter are used. More taps means more 
accuracy in the low end, but also means that 
the filter will cause more latency. The filters 
we generate are all linear phase with a 
symmetrical impulse response, and the 
latency is therefore equal to half of the filter 
length. 

Currently active filter You can add to the filter that is currently 
active in the hardware, or you can start from 
scratch by deselecting this option. 

HPF, LPF and PEQs You can choose which filter will be converted 
to FIR and which will be ignored. It is 
common practice to use IIR for low 
frequencies and FIR for higher frequencies to 
keep the latency down to a minimum. 

Track changes The FIR calculation will be updated 
automatically as you change PEQs. 

Invert RTA  
measurement 

�section 8.2 

Data from File �section 8.4 
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Select 256 taps (the maximum number for the hardware that is used for this example), deselect Currently Active FIR 
Filter and click OK. In the graphical screen you will see a dotted red line indicating the calculated FIR response. As you 

can see in the screenshot above, it is perfect as far as the display resolution allows us to see. The red dotted line is the 
calculated response from the FIR coefficients; so any deviations will be visible here. This becomes clear when we try to 
use this FIR filter to change the low frequency response:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig. 31  Calculated FIR response 
 
As you can see, the deviation below 200Hz is quite serious. In other words: A 256 tap FIR filter is useless in this 
frequency region. Which is to be expected, it is caused by the “finite” in the name FIR. You can use the red dotted line to 
see the result of the approximation 
 

8.2 Inverting the RTA measurement  

We can also create a filter by inverting the RTA measurement. Using the measurement we did in the previous chapter, 
the result looks like this:  
 
  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 32  Inverted RTA measurement 

 
As you can see, it only works above appr. 300Hz. Below that, the response is automatically reduced, taking the amount 
of taps into account. The red dotted line again shows the expected response 
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8.3 Loading a filter from a file 
Click CALC, then Load File. Select your file. If the number of taps in the file fit in the FIR filter, it will be loaded 

automatically. If the number of taps exceeds the available filter size, the filter will be truncated. ALLCONTROL supports 
24 and 32 bit fixed point files, and floating point files. Any lines that do not contain a number (such as comments) will be 
ignored. You can generate FIR files with many 3rd party programs, or even online. Here is a 1k HPF, generated with 
ScopeFIR:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig. 33  Loading a file 
 
Again, the dotted red line indicates the calculated frequency response.  
 

8.4 Sending a filter to the hardware  

When you are satisfied with the response indicated by the red dotted line,  
click APPLY to send the filter to the hardware. A window will appear with  

two options:  
 
Reset converted IIR filters: When selected, the software will automatically 

disable the IIR filters that were converted to FIR.  
 
Do not show this dialog again: Speaks for itself, doesn’t it? 

 
The communication can take some time to complete, depending on filter size and 
connection speed. 
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If no other filters are active, the response will be shown as a white line: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig. 34  Response 
 
When you add PEQs now, you will see the white line will follow the PEQs, as well as the red dotted line; the red dotted 
line is the newly calculated FIR filter, following the changes you are doing with PEQs, and the white line is the overall 
frequency response. If some PEQs are not taken into account in the FIR calculation, the white line will include them  
(because that is the overall frequency response) but the red dotted line will not. There will also be a solid red line, which 
is the response of the FIR filter that is currently loaded in the hardware: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Fig. 35  PEQ points 
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8.5 Saving files  

Click the disk icon next to the FIR block to save a filter as a text file. The filter that is loaded in the hardware will be saved 
to disk, and can be loaded into other channels or saved for later use. Here is the FIR file of this example (omitting most 
coefficients):  

 
FIR filter generated by DXO Control. Sample rate: 48828 Hz, 255 taps 
-0.00251117721317 
0.000136785209243 
0.000140666030413 
0.000148858875106 
0.000161494128481 
0.000177634880029 
0.000197263434621 
0.000219509005649 
0.00024409592163 
0.000270059332377 
0.000297261402149 
0.00032448116705 
0.000351532362565 
0.000377209857282 
0.000401332974621 
0.000422636978525 
0.000440970994737 
0.000454998575363 
0.000464653596498 
0.000468616374055 
0.000467024743774 
0.000458568334793 
0.000443564728109 
0.00042071472873 
0.00039056222904 
0.000351847149596 
0.000305717811131 
0.000250644981978 
0.000188274309127 
0.000117114745135 
3.95923853105e-05 
-4.697032275e-05 
-0.000135075300995 
-0.000237385742477 
-0.000340500846664 
-0.000444556586651 
-0.000553787686189 
-0.000663964078139 
-0.000775675289694 
-0.000885844231064 
-0.000994163565801 
-0.00109791569463 
-0.00119658745881 
 
 

Note: We believe that these functions provide you with powerful tools to use FIR filters and RTA measurements 

conveniently. Development is ongoing, so functionality will be added in the future. The examples in this 
document were made with software version 3.8.23 build 117010. Earlier software versions will have more 
limited functionality. Please always upgrade to the latest version as found on the product page at 
https://www.psso.de. 
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9 Output channel view  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
Fig. 36  Output channel input mixing 

   
To the left of an output channel graphical screen, level 
sliders are shown for each of the input channels (�Fig. 
36). This will allow mixing each of the input signals to each 
individual output channel. Even if Input channels are set to 
linked in the main screen, it is still possible here to mix 
individual input channels to an output channel in any 
desired ratio. Level setting is shown numerically below 
each slider. The available range is from 0 dB to -48 dB. As 
in other screen, double-clicking a slider resets it to 0 dB. 

 

9.1 Graphical screen 
A curve diagram of the magnitude frequency response is 
available for each output channel. The graphical area 
reflects the crossover settings for the channel in addition to 
any equalization settings set up in this screen, and is very 
similar to the available settings in the individual Input 
channel screens. The status of a parameter is always 
reflected in the blue on/off button next to each element. 

 

9.2 Relationship between input and 
output settings 

At the bottom of the output channel settings screen you will 
see the high-pass and low-pass settings from the 
crossover settings for the particular output channel 
repeated (�Fig. 14). Both the slope and the filter type are 
shown, and the curves are also shown in the output 
graphic screen. Any changes you make here are also 
reflected in the X-over screen. This way, you have control 
over the main crossover settings as well as the EQ and 
filtering for a specific output from a single screen. In 
contrast, the crossover screen gives you the overview of all 
crossover settings for all channels in a single screen. Both 
the HPF and LPF filter can be permanently disabled here 
of course, and that this will then also be reflected in the X-
over screen.  

 
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9.3 Output filtering and EQ 
Similarly as described for the input channels, each output 
channel can have up to 10 equalizers and filters attached 
to it. Note that all outputs can be configured individually 
independently from whether they have been linked 
elsewhere.  
 
Each EQ can be set in the graphical screen by dragging 
the appropriate EQ number as described earlier, as well as 
by entering the desired numerical values in the fields. 
When using the mouse to drag settings, the actual 
numerical values for Gain, Q or BW and Frequency are 
shown in the screen. In addition, the four icons in the top 
left area of the screen (expansion arrow, camera, ‘T’ and 
Looking Glass) act as described for the input screen.  

 

9.4 Curve diagram 
On the graphical screen, a white curve shows the 
compound transfer curve for that output channel. Each 
filter has a point of reference (small square with filter 
number) and a frequency curve in a specific color. Some of 
the filters can be set graphically via the mouse. 
 
There are two ways to toggle the contribution of an EQ or 
crossover element on the white compound curve on or off. 
You can either click the black/blue button next to each EQ 
or the HP or LP filter at the bottom of the screen, or you 
can double-click on the numbered square of the elements 
in the graphical screen. Even if the effect of the element on 
the compound curve is removed, the colored contributing 
curve of the element remains visible. This is a useful 
functionality to review the contribution of several interacting 
filter and EQ settings on a channel.  

 

9.5 Delay, limiter and compressor 
In the bottom right of the output screen there are settings 
for output delay, limiter (-46 to +24 dBu) and compressor 
release rate (13 to 99 dB/s) settings. Channel delay can be 
set in a variety of distance or time units from the drop-down 
list. 
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